Welcome to the new Europe i-PRO website! Choose your country/region under the Europe dropdown!

  1. Home
  2. Surveillance
  3. News & Events
  4. The i-PRO products and the log4J 2.X vulnerability

On December 9, 2021, a vulnerability for Log4j was publicly released.

 

This impacts all versions of Log4J from 2.0 to 2.14.1. In a nutshell, this vulnerability allows for remote code execution.

Please refer to the link below for more details :

https://nvd.nist.gov/vuln/detail/CVE-2021-44228

We have evaluated our products for the affect.

NO i-PRO products are affected by this vulnerability.

The following products have been reviewed and confirmed.

Products Example
Surveillance Network Cameras
Network Video Recorders
Video Management Software (e.g. WV-ASM, WV-ASF...)
i-PRO Software Tools (e.g. iCT...)
Video Insight VMS, Health Monitor Plus, MonitorCast
Medical Imaging Medical Imaging Products